Apple blocks Flash Player—AGAIN

Due to security issues in older versions, Apple has updated the
web plug-in blocking mechanism to disable all versions prior to
Flash Player 16.0.0.305 and 13.0.0.269.

Time to update your flash player once again.  If you have windows, you should do it too, because Microsoft is content to let you run out of date vulnerable versions for years.

Leave a Reply

Your email address will not be published. Required fields are marked *